Failures when launching new interactive sessions
Incident Report for renkulab
Postmortem

An erroneous change in configuration has led to unavailability of the Kubernetes plugin responsible for managing persistent volumes (CSI). Interactive user sessions on renkulab.io are backed by persistent volumes. While the CSI plugin was unavailable, no new user sessions could be launched. As soon as the faulty configuration change was rolled back, services became fully functional again.

Improving the test coverage of the code base which encodes the underlying infrastructure on which the services of renkulab.io are running will help us prevent outages like this in the future.

Posted Oct 19, 2021 - 12:28 CEST

Resolved
All services on renkulab.io should be fully restored.
Posted Oct 19, 2021 - 12:18 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 19, 2021 - 11:55 CEST
Update
We are continuing to investigate this issue.
Posted Oct 19, 2021 - 11:55 CEST
Investigating
Launching new interactive sessions is currently not possible. We are investigating the issue.
Posted Oct 19, 2021 - 11:37 CEST
This incident affected: Renkulab sessions.